Física con Excel: el interior de la Tierra (1)

La Tierra en capas

Estamos acostumbrados a vivir en la superficie terrestre y a considerar el interior como un montón de rocas, magma y regiones inaccesibles en general. Vamos a cambiar de chip. Dentro de la Tierra hay mucha física de interés, y vamos a usar nuestra hoja de cálculo para jugar con ella.

Una de las primeras cosas que nos enseñan de la Tierra es que está formada por grandes secciones concéntricas, cuyo nombre varía con el tiempo. Al principio muy interesante, pero luego vemos que son regiones inaccesibles y los profes comienzan a hablarnos de los plegamientos, los sinclinales y las rocas sedimentarias, con lo que nuestro interés por el interior de la Tierra se acaba limitando a volcanes y terremotos. Después, cuando vemos las leyes de gravitación, nos dicen que consideremos como si la Tierra fuese homogénea, y eso es todo.

Pero podemos echar mano de la imaginación y ver qué pasaría si tuviésemos una nave capaz de viajar por el interior de la Tierra, algo así como en la película El Núcleo. Vamos, por tanto, a simular nuestro mundo con una hoja de cálculo.

Lo primero que debemos tener en cuenta es que no sólo hay una estructura en capas, sino que esas capas distan mucho de ser regiones homogéneas. El modelo que vamos a usar se llama PREM (Preliminary Reference Earth Model), de A.M. Dziewonski y D.L. Anderson. Se basa en la suposición de que la Tierra tiene simetría de revolución, es decir, es como una cebolla esférica con capas donde la densidad depende solamente de la distancia al centro pero no de la latitud o la longitud. Si quiere, puede ver sus parámetros en una hoja de cálculo aquí, cortesía de Dave Typinski.

El modelo PREM comienza por un núcleo interno que se extiende hasta los 1.221,5 kilómetros desde el centro, y al que sigue un núcleo externo entre los 1.221,5 y los 3.480 kilómetros. A continuación, una capa llamada D’’ de 150 kilómetros de espesor da paso al manto inferior, que se extiende hasta los 5.700 kilómetros, siempre contando desde el centro.

A partir de ahí las cosas se complican un poco. Lo que en tiempos se llamó manto superior es ahora una combinación de tres capas llamadas zona de transición, zona de baja velocidad y tapa (“lid” en inglés). Finalmente viene la corteza terrestre, de espesor variable según estemos en el continente o en el océano.

Vamos a simplificar. Para empezar, consideraremos solamente cuatro capas, a saber: el núcleo interno, el núcleo externo, el manto y el exterior. En cada una de esas capas, el modelo PREM permite modelar la densidad como una función del radio: ρ(r)=ar2+br+c, donde (a,b,c) son constantes distintas para cada capa. He aquí esos parámetros para cada capa:

Núcleo interno Núcleo externo Manto Exterior
a -2,1773*10-10 -2,4123*10-10 -3,0922*10-11 0
b 1,911*10-8 1,4398*10-04 -2,444*10-4 -9,50*10-4
c 1,3088*104 1,2346*104 6,7823*103 9,306*103
r1 (m) 0 1.221.500 3.480.000 5.700.000
r2 (m) 1.221.500 3.480.000 5.700.000 6.371.000

Los parámetros (a,b,c) están expresados en unidades del Sistema Internacional para mayor comodidad. Pero antes de empezar, una aclaración. Como fundí todas las capas más allá del manto en una sola (“exterior”), tuve que construir por mi cuenta esos valores de b,c, y lo hice de forma que la masa total de la Tierra ajustase al valor conocido.

Bien, podemos ir construyendo nuestra hoja de cálculo. En la fila A introducimos la distancia al núcleo, en intervalos de 100 kilómetros; puede usted cambiar el intervalo en la celda B11 si lo desea. Para no pasarnos de tamaño he incluido una salvaguardia, de forma que el tamaño máximo de la distancia al centro sea el radio de la Tierra, de 6.371 kilómetros.

Segundo paso: simular la densidad. Para mayor comodidad lo he hecho en cuatro columnas, correspondiente a las cuatro capas (núcleo interno, núcleo externo, manto, exterior), y que ocupan las columnas C, D, E, F. Para cada columna se calcula la densidad ρ(r) según los parámetros (a,b,c) de la tabla anterior. Aquí hay que tener en cuenta un detalle importante, y es que hay que indicar cuándo estamos en una de las cuatro capas. Por ejemplo, en la columna F tenemos la densidad para el núcleo externo, y eso sólo sucede cuando la distancia al centro está comprendida entre 3.480 y 5.700 kilómetros (celdas H7 e H8). ¿Cómo decirle esto al señor Excel?

Entramos en el campo del álgebra booleana, y con esto hacemos un pequeño inciso. Las funciones de las hojas de cálculo tienen la posibilidad de incluir condiciones. Por ejemplo, supongamos que queremos hacer la raíz cuadrada de la cantidad que hay en la columna A1, y escribir el resultado en B1. Lo clásico es entrar en B1 y teclear =RAÍZ(A1). Sencillo, pero ¿y si resulta que A1 puede ser un número negativo? En tal caso todos los dioses de la matemática nos darán la del pulpo.

Para evitarlo podemos imponer una condición: la raíz solamente se hará si A1 es cero o positivo, y si no lo es el resultado será 55. Eso lo hacemos entrando en B1 y tecleando =SI(A1>0;RAÍZ(A1);55). La función SI(a;b;c) significa “si sucede a entonces el resultado es b, y si no sucede a entonces el resultado es c”

Constantemente usamos el álgebra booleana en nuestra vida. Si la bella Ana va a la fiesta entonces yo también voy, si no no. También puedo complicar la condición de partida. Por ejemplo: si Ana va a la fiesta y su novio Carlos no va, entonces yo sí voy, y si no no (no me gusta la competencia). O: si Ana o Belén van a la fiesta yo voy, y si no no (me gustan las dos). O bien: si Ana va y Belén también va yo voy, y si no no (me gustan los tríos). Como ven, podemos complicar la condición de partida todo lo que queramos.

En el caso que nos ocupa, vamos a irnos a la columna E, concretamente a la celda E17. La densidad es igual a ρ(r)=ar2+br+c, como hemos visto antes. Los parámetros a,b,c están en las celdas G4, G5, G6 respectivamente. Por tanto podemos obtener la densidad como G4*A16*A16+G5*A16+G6. Queremos que la distancia al centro (celda A17) sea mayor (o igual) que r1 y menor que r2, los radios límite del núcleo externo. Esos radios están en las celdas G7 y G8. La primera condición (que A17 sea superior o igual a G7) se podría poner como

=SI(A17>=G7;G4*A16*A16+G5*A16+G6;0)

Pero tenemos una segunda condición, que A17 sea inferior a G8. Para escribir esta segunda condición podemos hacer dos cosas. Una de ellas es escribir la condición como producto de tres términos:

=SI(A17>=G7;1;0)*SI(A17<G8;1;0)*(G4*A16*A16+G5*A16+G6)

con lo que el primer término será 1 si se da la primera condición, el segundo término será 1 si se da la segunda condición, y el tercer término nos da el cálculo que queremos. Podrá comprobar que así he calculado las columnas D, E, F y G.

También podemos incluir el tercer término en algunos de los SI (condicionales):

=SI(A17>=G7;G4*A16*A16+G5*A16+G6;0)*SI(A17<G8;1;0)

o bien

=SI(A17>=G7;1;0)*SI(A17<G8;G4*A16*A16+G5*A16+G6;0)

Cualquiera de las dos vale. Pero hay una notación más compacta que permite fundir las dos condiciones en un solo SI. Es así:

=SI(Y(A17>=G7;A17<G8);G4*A16*A16+G5*A16+G6;0)

La novedad es la parte “Y(A17>=G7;A17<G8)”. El Y significa que se deben dar las dos condiciones: A17>=G7 y A17<G8, las dos simultáneamente. Si no es así, es decir, si estamos en el núcleo interno (A17<G7) o en el manto (A17>G8), esa densidad nos da cero.

Y aquí acaba el inciso sobre álgebra booleana. Si quiere aprender más sobre el tema, le recomiendo que lo haga porque resulta muy útil en temas que van de los cálculos en Excel a las búsquedas en Google. Y ahora prosigamos. Hay un detalle a tener en cuenta, que ya comenté en la anterior entrega de Física con Excel. Se trata de las posiciones relativas. Si yo hago que la celda E17, la correspondiente al núcleo interno, sea:

=SI(Y(A17>=G7;A17<G8);G4*A16*A16+G5*A16+G6;0)

puedo copiar y pegar en el resto de la columna E. Bien. Pero si intento copypastear el resultado a la columna F, la del núcleo externo, el resultado será:

=SI(Y(B17>=H7;B17<H8);H4*B16*B16+H5*B16+H6;0)

y con ello A17, que almacena la distancia al centro, se convierte en B17, que no tiene nada que ver. Para hacer un buen copypasteo la columna A tiene que permanecer invariante, y tampoco quiero que cambien la celdas que me indican los parámetros (a,b,c), los radios, etc. Por eso la celda E17 queda así:

=SI(Y($A16>=H$7;$A16<H$8);(H$4*$A16*$A16+H$5*$A16+H$6);0)

De acuerdo pues. Es hora de ver alguna gráfica para despejarnos de tanta lógica booleana:

Las densidades van cayendo con la distancia, y también disminuyen según vamos del núcleo interno (azul) al externo (rojo), el manto (naranja) y el exterior (verde). Como comparación, la densidad media de la Tierra, suponiendo una esfera homogénea del mismo tamaño y masa, es de unos 5.510 kg/m3.

Saber la densidad a cada distancia nos permitirá calcular muchas cosas, y en las próximas entregas nos dedicaremos a jugar con nuestro simulador de Tierra. Pero hoy no, porque no quiero sobrecargarlos el primer día. Vamos a dejarlo aquí por ahora.

[Hoja de cálculo disponible: Interior de la Tierra 1]

Deja un comentario

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *

*